Systems covered by this article
This page is for Concord surveillance systems whose model names end in ...-A, ...-P, ...-V2, or ...-V3 only.
You will find the model name on the white sticker on the lid of your system - it looks like CNKxxxxx-V2.
For V4 Concord systems bought after August 2025, please download the App Concord Connect.
Issue
Your phone doesn't work with the Concord Security App, or it can't display your cameras correctly.
Cause
Your phone may have configuration issues that prevent the Concord Security App from working.
Solutions
Removing the App, restarting the phone, and reinstalling the App may help. Make sure you press Allow to any popups the phone gives you after opening the App.
Otherwise, install an alternative App (RXCamView) that also works with Concord systems:
Android: https://play.google.com/store/apps/details?id=com.client.rxcamview&hl=en_AU
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Apple: https://apps.apple.com/au/app/rxcamview/id1062447553
Connect your system using this App as shown below.
Open the App and press Allow to any popups it gives you.
Android: Press Setting & Allow for background power usage
Press Deny to this one below
Press OK on the bottom of the overlay
Press the three bar menu on the top left
Press Device List
Press the + on the top right, then press IPC/NVR/DVR
Allow any permissions it requests
Scan the QR code on the label stuck to the lid of your Concord system
Type your password and press Save
If you log in with a name other than admin in the Concord Security App, type it here
Your Concord system should appear and say Connected.
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